Developers

World class technical support for all Omnis programmers.

At TigerLogic we recognize that development support is as important as the software we provide,
vital in allowing you to develop, deploy and maintain your Omnis applications as quickly and as easily as possible.
 

Javascript Client and Internet Explorer 8

February 2015

In order to support Internet Explorer 8.x with Studio 6.1, please download the replacement scripts below. These should be placed inside the Studio html/scripts folder, replacing the existing files.

Non-compliance with the HTML5 standard together with various performance and compatibility issues means that Studio 6.1 is the last version that will support Internet Explorer 8. Please note that the Javascript Client will not support Internet Explorer 8 in future versions. Download replacement scripts.

Omnis Studio 5.X and Mac OS 10.10 (Yosemite)

November 2014

Removal of the Open Transport network layer from Mac OSX 10.10 means that versions of Omnis Studio prior to version 6.0 will not work on this platform. Data Access Modules and networking functions are affected.

Please be advised that you should not upgrade to Mac OSX 10.10 (Yosemite) unless you are using or plan to use Omnis Studio version 6.0 or later. We apologise for any inconvenience this may cause our developers.

Omnis Studio on new installs of Mac OS 10.9 (Mavericks) & 10.10 (Yosemite)

October 2014

Java is no longer installed by default on newly installed copies of Mac OS X 10.9 (Mavericks) or 10.10 (Yosemite). Therefore Omnis will exit on launching with an error message indicating that you need to install an obsolete version of Java (i.e. version 6.x).

To remedy this you need to download and install the obsolete 32-bit version of Java from the Apple website (http://support.apple.com/kb/dl1572): note the 64-bit version of Java is not compatible with the current shipping version of Omnis Studio which is 32-bit only. For more information please refer to 'Java for OS X 2013-005 and Java for Mac OS X v10.6 Update 17' on the Apple support website.

Having downloaded and installed the 32-bit version of Java, there should be no further changes required for Omnis Studio. In addition, and as far as we are aware, there should be no issues when you install the later version of Java, as they will co-exist with the obsolete 32-bit version on the same computer.

Mac OS X support for Omnis Studio 5.x

October 2013

Please note that the PostgreSQL DAM in Studio 5.1 has compatiblity issues with Mac OSX 10.9 and later. This is because Open Transport was removed from the Core Services Framework in the OS X 10.9 Mavericks SDK.

To use the PostgreSQL DAM with Studio 5.1 & Studio 5.1.1, a replacement DAM is required (available from the ODPP download area). If using Studio 5.1, a replacement libpq.dylib is also required. This may be obtained from the ODPP download area or copied from a later version of Studio if preferred).

This issue does not affect Omnis Studio 5.2.

Mac OS X support for Omnis Studio 4.x

October 2013

Please note that Omnis Studio 4.x is not supported with Mac OSX 10.9 and later. This is because Open Transport was removed from the Core Services Framework in the OS X 10.9 Mavericks SDK.

As a consequence of this, the Studio 4.3 WebEnabler and FileOps components no longer work. Omnis commands TCPConnect/Send/Receive/Close, HTTP..., SMTP..., POP3, MailSplit, HTTPSplitHTML and FTP... are also affected. The trace log will warn that the web enabler external fails to load and any web enabler commands will replaced by tokens (X2345678...).
Although it may be possible to rewrite some of these commands to use TCPTalk functionality, there is no automatic process in place to achieve this. In these cases, upgrading to Studio 5 is may be preferable.

This issue affects Omnis Studio versions 4.3, 4.3.1 and 4.3.2.x. Studio 5.0 and later use a more recent SDK and are not affected.

Omnis Studio oOLE2 Component

December 2014

As of Omnis Studio 6.1, the OLE2 component is no longer shipped with the product. If you wish to restore support for OLE2, please download the oole2.dll and place inside the Omnis\xcomp folder.

oOLE2 (Windows 32-bit only) oole2.dll (208KB)  

Further information on the OLE2 component can be found in the Omnis Programming Manual.

Microsoft Small Business Server (SBS) 2011

May 2011

Microsoft Small Business Server (SBS) 2011 includes server class applications such as Exchange, SharePoint and SQL Server, which can contend for system resources. Based on the level of usage of the Microsoft applications, Omnis Studio may perform at a level lower than required.

If Omnis Studio running on SBS 2011 does not perform to your requirements, it is recommended that Studio be installed on a dedicated Windows server. If you have any questions regarding the use of SBS 2011, please contact TigerLogic Technical Support or see the following link for the differences between "Standard" & "Essential" versions of 2011: www.microsoft.com/sbs/en/us/compare-features.aspx

JPEG & PNG images on Mac OS X platforms

September 2010

With the assistance of Michael Mantkowski of Cleintrax Software, we have discovered a limitation of the drawing code on the Mac OS X platforms (Intel & PPC).

The problem is occurring because the row size of the picture data when converted to 4 bytes per pixel pixmap is larger than 0x3FFE (16382) bytes.

We will only be able to resolve this matter when Omnis Studio for the Mac OS X platform is ported to Cocoa in the future. In the meantime, the workarounds are to ensure that you use smaller JPEG & PNG images, or re-size the existing images with a suitable third party tool.

Omnis Studio and 64-bit Operating Systems

January 2011

Omnis Studio has been tested and is certified for use with Windows 64-bit operating systems: Windows XP, Vista, 7, 2003 Server and 2008 Server, as well as 64-bit editions of Mac OS X (10.5 & 10.6). Currently, we do not provide support for 64-bit Linux systems.

Please note that Omnis Studio is a 32-bit application and is not interoperable with 64-bit software. For instance, data connectivity requires use of 32-bit ODBC Administrator plus 32-bit clientware with any DAMs used.

File Locking Issues under Mac OS X

Click here for important information regarding the use of Omnis datafiles on OS X.

Windows Support for Omnis 7

Outlines Windows XP and 2000 support for Omnis 7.3.

End of Life Notification for Non-Visual Informix DAM

This notification pertains to the DAMIFX component. Studio 4.2 will contain the final release of this component which will no longer be distributed with future versions of Omnis Studio. Currently only available (and stable) on the Win32 platform, this component no longer conforms to our cross-platform philosophy. We will endeavour to provide support for OS critical issues only- as deemed appropriate.

End of Life Notification for Old-Style (V2) DAMs

This notification pertains to the DOMNIS, DODBC, DORACLE, DORACLE8, DSYBASE, DINFORMX & DDB2 DAMs which have been superceded by the multi-threaded object DAMs. Omnis Studio 4.1 will contain the final releases of these DAMs which will no longer be updated in future versions of Omnis Studio and no longer available as of Studio 5.0. We will endeavour to provide support for OS critical issues only- as deemed appropriate.

End of Life Notification for Non-Visual Oracle7 DAM

This notification pertains to the DAMORA7 component which has been superceded by the non-visual Oracle8 DAM (DAMORA8). Omnis Studio 4.1 will contain the final release of this DAM which will no longer be distributed with future versions of Omnis Studio. We will endeavour to provide support for OS critical issues only- as deemed appropriate.